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Photos Takeout enables you to export photos and videos from Mac Photos library in neat 
folders. It’s easy to use: Just select years, albums or moments and click Export. 
 

v Before launching Photos Takeout, ensure that the library you plan to export from is set 
as the System Library in Photos (Check in Photos > Preferences > General) 

v If the photos you select for export are in iCloud, Photos Takeout will download and export 
them. Ensure your Mac has enough free space to accommodate those photos. 

 
Control Panel 
On launching Photos Takeout, you’ll see this screen: 
 

      
 

Click ‘Turbo’ or ‘Standard’ method, and select your source Photos library. Then, in the 
left pane, specify the export destination and other parameters (Explained below). At 
bottom left of the screen, you’ll see the number of photos and videos in the library. 

In the right pane, select whether to export Year, Album or Moment/Day-wise folders, and 
which years, which albums etc. 

v If you see Error: Database is locked alert, it means that Mac Photos is open. Quit it. If 
the issue persists, see FAQ at the end of this Guide to learn how to release the lock.
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Left pane 

Source: Your active Photos Library contains the photos and videos that you see in Photos 
app, and Photos Takeout will display and export those. 

      

In Catalina and Big Sur, the current system library is used for exports. To export from 
another library, first make it the system library in Photos Preferences (Refer to the FAQ 
to see how). Then, in Photos Takeout, click Source and select the same library. If the 
source library that you specify in Photos Takeout isn’t the same as the system library in 
Photos, exports may be incorrect or incomplete. 

 

 
The Photos Library is usually located the Pictures folder. If you have multiple libraries, 
find and select the one you want to export from, then click Open. 

 

 
v You’ll need Power version for libraries of up to 50GB; Pro Power for larger ones. 

 
v Library size shown by Photos Takeout only includes photos and videos, while Photos 

app also includes database, thumbnails etc. As such, the sizes may differ a bit. 
 

Destination: In the left pane, click below Destination and specify where you want to save 
the exported folders, e.g. Mac’s desktop, Dropbox, Google Drive, flash drive etc. 
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Export options: Use these to refine the selection of image assets to be exported. 

 
- Keep subfolders: When exporting Year-wise folders, check this box to get month- 

wise subfolders within the years. The subfolders are named 1 (for Jan), 2 (Feb) and 
so on. When exporting Albums or Moments (Days), this option is greyed out. 

 
- Keep metadata: If you check this, Photos Takeout will export all EXIF/IPTC metadata 

and any titles, descriptions, keywords or locations that you have added in Photos. If 
you want to remove metadata for privacy or other reasons, uncheck this box.  

 
- Unmodified: Leave this box unchecked to export the latest versions of photos and 

videos with all your edits. To export the unmodified originals, check it. 
 
- Keep ordered: Using Photos app, if you export an album in which you have custom 

rearranged photos, the ordering is lost after export. Photos Takeout preserves the 
ordering if you check mark Keep ordered (Only in Catalina and later). Items in the 
album are renamed and renumbered as album-name 000n.filetype. 

 
- Media selector: To choose between Photos & Videos, Photos Only, Videos only. 

 
- Incremental: To export only the items added or edited since the previous export. 

 
Right pane 

Category buttons: These three buttons show the Year, Album and Moment counts: 
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To export all the years, all albums or all moments/dates that exist in your library, click on 
the relevant top level button, and click Export.  

To select specific years, albums etc., click on the relevant button. This expands the view 
to show the selected category’s folders, and the number of items in each folder. 

      
 
To export specific folders, e.g. only two of the five albums above, select from the lower 
level tiles (⌘-click), and click Export. If Photos Takeout can’t find some photos, it will alert 
you. See FAQ (Q4 and 5) for what to do. 
 
Free Trial and Upgrading 
 
• Free version: Experience how the app works. Exports only 1 photo per folder. 

 
• Power version: For Photos libraries of up to 50GB in size. Unlimited exports. 

 
• Pro version: For larger libraries. We have tested with libraries of up to 2.4 TB. 

 
• Power Up: If you have purchased the Power version, you can upgrade to Pro Power 

version with this purchase (Pay just the price difference between the two versions).
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FAQ and Troubleshooting 
 
GENERAL 
 

1. How does Photos Takeout differ from Photos app in exporting? 
 

If you export multiple albums or all photos of selected years with Photos, they are all 
dumped into one humongous folder. Photos Takeout saves them in proper folders. 

2. I have a 2.5 terabyte library. Will Photos Takeout be able to handle it? 
 

Yes, there is no size limit. Use the Power version for Photos libraries of up to 50GB; 
the Pro Power version for libraries of any size.  

3. Are photos and videos exported in the original or reduced resolution? 
 

Resolution is preserved. Photos Takeout does not alter photo quality. 
 

4. Is metadata preserved when exporting, for both photos and videos? 
 

Yes. Check ‘Keep metadata’ box to retain all the EXIF and IPTC metadata, as well 
as Title, Description, Location and Keywords that you’ve added in Photos app. 
 

5. Does with the M1 Silicon Macs? What if I upgrade from my old Mac to M1? 
 

Yes, Photos Takeout works on both Intel and M1 Silicon-powered Macs. It will also 
work if you purchase it on your Intel Mac and later upgrade to an M1 Mac.  

 
 
USING THE APP 
 

1. I have multiple Photos libraries. How to change the system library? 
 

Open Photos. Change the current system library to the one that you want to export 
from, as explained here. Close Photos app, then launch Photos Takeout. 

 
2. I get ‘Error: Database is locked message’ on launching the app. 
 

Photos and Photos Takeout shouldn’t be open concurrently. Quit Photos. Open Activity 
Monitor. Select and quit Photos Agent and photolibraryd (View > Quit process). 
 

3. There are two user accounts on my Mac. Can Photos Takeout run from both? 
 

Yes, if Photos Takeout is installed in the shared Applications folder. Log in to the App 
Store from the other account using the Apple ID with which the app was purchased. 
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4. I launch the app and select Turbo or Normal mode. Then I can’t select the Photos 
library: On trying to select it, the Open button is greyed out. 
  
Select the library (Red arrow in the screenshot below), not the expanded folders within 
it. Single-click to select it, don't double-click it and don’t select the folders to its right. 
 

 
 
5. On selecting Source, the spinner keeps turning for ages. Is the app hanging? 
 

No. Depending on your library’s size, it will take a few seconds to several minutes to 
load. A 100GB library may take 3-4 minutes to load; 1TB library 45 minutes. 

 
6. App shows zero items in Years, Albums and Moments. Also, nothing happens 

when I click the Years, Albums or Moments buttons. See screenshot. 
 

      
 

Even if Source in the left pane shows your library’s name, you must click below Source 
and reselect the system library. This grants Photos Takeout access to your library. 
 
Another reason may be version mismatch, e.g. trying to use a Catalina library on a Big 
Sur Mac, or a Big Sur library on a Mojave Mac, or (uh) an iPhoto library on any Mac. 
 

7. How to select multiple albums or years for export?  
 

To select all items, Press Command-A or click Edit > Select All. To select multiple non-
contiguous items, hold down the Command key and click each item. To select a range 
of contiguous items, hold down the Shift key (or Shift + CMD), then click the first and 
the last items. Or drag with mouse to select the items within the selection rectangle. 

 
 
 

 



7  

8. Not all the items were exported. It said: “X files exported. Y not found.” Why? 
 

If you see a message like this, it can be due to a few different reasons:  
 

        
 

 
- Wrong library: If using Big Sur or Catalina, and all the missed items are iCloud-

based or edited photos, it’s because the library you have selected as Source isn’t 
the same as your current Photos system library. Correct this, then retry.  

 
- Photos in iCloud: In Mojave and older, you must download the photos from iCloud 

before initiating export (See how, below). This is not necessary for Catalina and Big 
Sur libraries – Photos Takeout does it for you. 

 
- Inability to access files: e.g. missing referenced files, hidden photos and other odd 

cases. A text file of items not exported is saved, so that you can investigate. 
 
- No file permission: Mostly with referenced files. See where these are located and 

that you haven’t moved, renamed or deleted them. Contact us with the details. 
 

9. How to download photos stored in iCloud to Photos app on my Mac? 
 

Launch Photos, click Photos > Preferences > iCloud > select Download Originals to 
Mac. Once they are downloaded, use Photos Takeout to export the required folders.  
 
Doing this is necessary only in Mojave or older mac OS. 

10. I renamed some pictures in Photos app. If I right-click any photo and select Get 
Info, I can see both names. But after exporting, I only see one name. Why? 

 
Apple Photos stores original as well as edited file names, but Photos Takeout only 
keeps the edited names. Also, if multiple photos have the same name, they’ll be 
sequentially numbered e.g. Vacation 1.jpg, Vacation 2.jpg etc. 

 
11. I exported photos to external HD but they’re all zero kB and can’t be opened. The 

error message says “File could not be opened because it is empty” 
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Check the EHD format (Right-click EHD icon on the desktop > Get Info). It should be 
APFS or Extended Journaled, not MSDOS (fat 32) or ex FAT, which are incompatible 
with mac OS Big Sur. 
 
To confirm that EHD format is causing this problem, export a single year or album to 
your Mac desktop and see if it exports correctly.  

 
12. How to export shared albums or smart albums? 

 
Save the photos from the shared or smart album as a regular album under My Albums, 
then you’ll be able to export it just like other albums. 
  

13. I want a complete backup. If I export all albums, that won’t be complete because 
photos not assigned to any album will be left out. What to do? 
 
Create a smart album of all such unassigned photos, then also export this album. In 
Photos app, click File > New Smart Album, and use the following selections: 
 

 
 

14. How does Photos Takeout handle export of raw images? 
 
Raw photos may have been imported into Photos as raw-only or raw-jpeg pairs. For 
both cases, Photos Takeout exports according to the following rule: 
 
Unmodified check-marked: Only the unedited original RAW file will be exported. 
 
Unmodified unchecked: Only the latest edited JPG version will be exported. 
 

15. My current system library on Mac syncs with iCloud. I also have a library on EHD 
that’s too big for Mac or iCloud. If I set this as my system library for using with 
Photos Takeout, won’t it start uploading to iCloud? 
 
You don't need to upload the photos from your external HD-based library to iCloud – or 
even to your Mac. Use the following workflow: 
 

- Temporarily disconnect the Mac from iCloud. See how. 
- Connect EHD to Mac. In Photos Preferences, make the EHD library the system library. 
- Launch Photos Takeout and export whatever you want 
- Reverse Step 2 (Disconnect EHD; revert to normal Photos and iCloud settings). 

 
16. My photos are in iCloud (Photos > Preferences > iCloud > Optimize storage is 

checked). If I export all years or all albums, will the photos be downloaded to 
Mac before export? What if there isn’t enough free disk space on the Mac? 
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On Catalina and Big Sur, Photos Takeout will download the items to be exported from 
iCloud. On Mojave and older, you must first download them into the Photos library and 
then export. If your Mac doesn’t have enough free space, move your Photos library to 
an external hard drive as explained here, set this EHD library as the system library (in 
Photos > Preferences), delete the original library from the Mac, then export. This will 
download the photos from iCloud to the library on EHD instead of Mac. Note that the 
app may hang if your Mac doesn’t have enough free space to download the photos 
you’ve selected from iCloud. 

 
17. The progress indicator is stuck at X% and the app seems to be hanging. 

 
For photos in iCloud, Photos Takeout downloads them to the Photos library on your 
Mac and then exports them. So your Mac must have enough free disk space for the 
download. Also, downloads from iCloud can take long, especially if you have a lot of 
files. In rare cases, the progress indicator may run ahead and wait for the download 
and export to catch up. At such time, the app may appear to hang even though the 
export is continuing. You could abort the export, download the assets from iCloud, 
and export them with Photos Takeout only after downloading is complete.  
 

18. Face recognition information is not exported as part of metadata? 
 
Face recognition information is not part of EXIF or IPTC metadata, but you can add 
the names of people in photos in the IPTC keywords field. To do this, go to People 
view in Photos > click on a face > the photos containing that face will be displayed > 
Select all > right click, Get Info > add the person's name in keywords. 
 

19. How to export incrementally, i.e. only the photos added or edited since the 
last time I exported my library? 

 
 Click ‘Incremental exports’ in the Options panel, and follow the on-screen commands. 

Refer to Help > Incremental Exports for detailed guidance. 
 
 
OTHER 
 

1. How to export only selected photos or videos (not folders)? 
 

Do it from Photos app, not Photos Takeout. Select the items and either drag and 
drop in your desired location or (for more options) click File > Export. 
 

2. Does Photos Takeout work with iPhoto or Aperture libraries? 
 

No, Photos Takeout is only meant for Photos app. Not iPhoto or Aperture. Convert 
those libraries to Photos, then export with Photos Takeout. 

 
3. Can I open a Photos library fetched from a Mac running Mojave with Photos 

Takeout on a Mac running Catalina? 
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No, you can only use a Photos Library that can be opened with Photos on that Mac. To 
use a Mojave library on a Catalina Mac, first import it into Photos for Catalina. Note 
that you can’t downgrade a Catalina library to Mojave. 

 
4. My question isn’t answered here. 

 
Please email us through the app, explaining the issue and stating your Mac and OS 
version, how many items in your library, size of the library (GB), library location (on 
Mac or EHD), location of photos (locally in Mac Photos, iCloud or referenced); and 
the export destination (Mac, EHD, NAS, cloud storage etc.) The more information 
you provide, the faster we’ll be able to analyze and troubleshoot the issue. 
 
This FAQ document is enhanced frequently by incorporating the latest questions 
asked by users, so we encourage you to review it from time to time. 
 

KNOWN ISSUES 
 
1. Since March 2021, we are developing features only for Catalina and later versions 

of mac OS. The app works mostly fine on Mojave and older, but some things don’t. 
For example, from iCloud need to be downloaded to the local library before export, 
keywords are not exported 
 

2. Metadata added to videos via the Photos app is not retained upon export (Note that 
this also happens on exporting with Photos app – Date & Time original are retained 
only when you exported unedited originals, not in edited videos. 

 
3. Referenced files aren’t exported in Big Sur (We are working on resolving this). They 

are exported normally in Catalina, Mojave and older. 
 
4. Progress indicator does not accurately reflect export progress when a lot of files are 

in iCloud. 
 
5. File naming convention: We plan to add more flexibility in how exported files are 

named, e.g. adding YYYY-MM-DD prefix. 
 
6. Incremental exports: Edited items sometimes fail to export. 


