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Photos Takeout exports photos and videos from Mac and iCloud Photos into folders. This 
concise guide explains its features and requirements. 
 
Before starting your export, ensure that: 
 

❖ Photos Takeout has access permissions1. In System Settings2 > Security & Privacy > 
Privacy > Photos, the Photos Takeout box must be check marked. 

❖ Source is your system photo library3 (Check in Photos Settings.) 

❖ Your iCloud storage and the drive housing the Photos library are not full. 

❖ Destination drive has enough free space to save the photos you’ll export. 

❖ If Destination is an external drive, it is formatted as APFS / extended journaled4. 

 

Home Screen 

On launching Photos Takeout, you’ll see the Home screen: 

 

 
 

This view, with photo thumbnails, is Icon View. You can switch to List View via the buttons in 
Years or Albums tabs. We recommend using List View – it’s 20% faster than Icon View. 

 

In the left pane, specify the source Photos library, the destination and export preferences. In 
the right pane, select which Years, Albums or Days to export. Click Export to start exporting. 



2  

Left pane 

Source: Photos Takeout will export photos from this library. If you have more than one Photos 
library, ensure that you choose the current system library as the source. 

 

                
 

To export from a library that’s not currently the system library, first set it as the system library 
in Photos > Settings (Preferences in old versions of macOS).  If the Source library is not the 
system library, none of the iCloud-based, edited and referenced items will get exported. 

 

 
The Photos Library is normally located in the Mac’s Pictures folder, but it can also be located 
elsewhere, e.g. on an external drive. Select it, then click Open.
See footnote5 if you have difficulty in selecting the library).

 

                      

 
Depending on your library’s size, it may take several seconds (even minutes) to load. 

 

Destination: Specify where to save the exported folders, e.g. Mac, Dropbox, external drive 
etc. The destination drive must have enough free space to accommodate the selected 
items. We recommend using a drive formatted as APFS or extended journaled.
 

Export options: Use these filters to fine tune the selection of items to be exported. 

 

- Include metadata: Check marking this will embed all EXIF/IPTC metadata as well 
as any titles, descriptions, keywords or locations that you have added. If you want to 
remove metadata for privacy or other reasons, uncheck this box. 

 
- Include edits: Check mark this box to export the latest versions of photos and 

videos with all your edits. To export the unmodified originals, uncheck it. 

https://photostakeout.com/apfs-vs-exfat/
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- Include Folders: If you have organized the selected albums in folders, check 

this box to export the albums along with the folder-subfolder hierarchy. 
 

- Ordered albums: If you have rearranged photos in an album, check mark  this box 
to preserve the custom sequence. Items in the album will be renamed as album- 
name 000n.filetype (Feature available only in Catalina and later). 

 
- Include subfolders: When exporting Years, check this box to get monthly subfolders. 

They will be named 1 (for Jan), 2 (Feb) etc. For Dates, this option is greyed out.  
 

- Media selector: To choose between Photos & Videos, Photos Only, Videos only. 
 
- Incremental Exports: Option available only in List View. If you have previously exported 

Years or Albums, this feature lets you update those folders by exporting only the photos 
or albums added or modified since the previous export. For details of this powerful 
feature, click Help > Incremental Exports in the app. 

 

Right pane 
 

 
 

Click on the Years, Albums or Moments buttons to expand the view. Within the Years 
and Albums tabs, you’ll also find the buttons to switch between Icon and List views. 
 
Icon View shows the selected category’s folders, item counts, and thumbnails. If albums 
are arranged in folders, the folder names will appear on top left of thumbnails (This is the 
legacy view, we recommend using List View for exporting. See below). 
 

 

 
 

 
List View allows you to make a more granular selection, e.g. you can select specific 
months to export within a year, or specific albums within a folder. Also, if you plan to use 
Incremental Exports to keep the exported folders updated, you must use List View.6
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To select multiple non-contiguous folders, ⌘-click them. To select contiguous folders, 

click the first folder, then hold down Shift and click the last folder in the range. 

 
Select Years, Albums or Dates to be exported, and click Export. A progress indicator will 
show % complete. If any photos fail to export, you’ll get an alert. See FAQ for what to do. 
 

Free Trial and Upgrading 
 

• Free version: To check out how the app works. Exports only one photo per folder. 

 

• 1 Month: Inexpensive option for users wanting to export photos on a one-off basis, or to 
use Incremental Exports to bring previously exported folders up to date. It’s a non- auto-
renewing subscription, so don’t worry that you may be charged again next month. 

 

• One Time: This perpetual license is ideal for professional and long-term users.  
 

Both paid options allow you to export all sizes of Photos libraries. Earlier versions of Photos 
Takeout made a distinction between Power (up to 50GB) and Pro (larger) libraries. That 
distinction no longer applies. 
 

 
Contact Us for Support 
 
See below (at the end of FAQ and Troubleshooting section). 
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FAQ and Troubleshooting 
 

GENERAL 
 

1. I have a multi-terabyte library. Can Photos Takeout handle it? 
 

Yes, Photos Takeout is size-agnostic. Library size equals photos saved in the Mac 
Photos library plus those in iCloud and any referenced photos. 

 
2. Are photos and videos exported in the original or reduced resolution? 

 
Everything is exported in original resolution. For lossy formats e.g. JPG, the file size (MB) 
may differ a bit but resolution (MP) stays the same. 

 
3. Is metadata preserved when exporting, for both photos and videos? 

 
Yes. Check ‘Keep metadata’ box to retain the EXIF and IPTC metadata, as well as Title, 
Description, Location and Keywords that you’ve added via the Photos app. 

 
4. I have two Macs. Do I need to buy two licenses to use Photos Takeout on both? 

 
You can use one license on up to 6 Macs. Log into the other Mac with the Apple ID you 
used to purchase the app, and you’ll be able to download it free from the App Store. 
 

5. I have 50,000 photos. If I try to download directly from iCloud.com, it only lets me 
select 1000 photos at a time. What about Photos Takeout? 
 
There is no such limit for Photos Takeout; it can export everything in one go. 

 

USING THE APP 
 

1. Where is my Photos Library located? 
 

Its default location is in User/Pictures folder, and it has the same icon as the Photos app. 
If it’s not there, you may have stored it elsewhere on your Mac or on an external drive. 

 
2. I found the Photos library but how to select it? The ‘Open’ button is greyed out. 
 

Select the library (Red arrow in the screenshot below), not the folders within it (database, 
attachments etc.) Single-click to select the Photos Library, don't double-click on it. 
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3. How to export from a Photos library that’s not the system library?  
 

For Catalina or later, Photos Takeout exports photos stored in iCloud, edited photos and 
referenced items only if the system library is set as the source. To change the system 
library, open Photos > Settings > General > Set the desired library as the system library, 
as explained here. Close Photos app, then launch Photos Takeout. 
 
For Mojave and older, you must first download photos stored in iCloud to the Mac Photos 
library, then export with Photos Takeout. Source doesn’t have to be the system library. 

 
4. There are two user accounts on my Mac. Can Photos Takeout run from both? 
 

Yes, provided that Photos Takeout is installed in the shared Applications folder. 
 

6. App shows zero items in Years, Albums and Dates. Nothing happens when I click 
the Years, Albums or Dates buttons. What to do? 

 
Open Settings (System Preferences) > Security & Privacy > Privacy > Photos, and check 
mark Photos Takeout. After this, even if Source is already set, click it and reselect the 
source (= system photo library). This grants Photos Takeout access to your library. 

 
Another reason may be version mismatch, e.g. using a Catalina library on a Sequoia 
Mac, or a Sonoma library on a Mojave Mac, or an iPhoto library on any Mac. 

 
7. How to select multiple albums or years for export?  
 

To select all items, Press Command-A or click Edit > Select All. To select multiple non-
contiguous items, hold down the Command key and click each item. To select a range of 
contiguous items, click the first item, then hold down the Shift key and click the last item. 
Or drag with mouse to select the items within the selection rectangle. 

 
8. Some items failed to export. Error message: “X files exported. Y not found.” 

 
Several possible reasons; the main ones are listed here. Try to eliminate these. If the 
problem persists, contact us with the details. 

 

9. How to download photos stored in iCloud to Photos app on my Mac? 
 

You need to do this only in Mojave or older. In Catalina and later, Photos Takeout can 
export full resolution photos directly from iCloud. To manually download photos from 
iCloud, go to Photos > Preferences > iCloud > select Download Originals to Mac. Once 
they are downloaded, use Photos Takeout to export.  

10. I added Titles to photos, and in the Photos app I can see the original file names as 
well as Titles. But after exporting, I only see one name. Why? 

 

https://support.apple.com/en-in/HT204414
https://www.facebook.com/PhotosTakeout/posts/pfbid0ujNLMN7SJXj6G7s38qgPbniMbSY9GyuADKDzqAf2WLS9uys7Naj3pbqcLUs8z7VAl
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Apple Photos stores original file names as well as Titles. Photos Takeout keeps Titles if 
present, otherwise the original names. Also, if multiple photos have the same name, 
they’ll be sequentially numbered e.g. Vacation 1.jpg, Vacation 2.jpg etc. 

 
11. I exported photos to external HD but they’re all zero kB and can’t be opened. The 

error message says “File could not be opened because it is empty” 
 

There may be a permissions or formats issue on your destination drive. To check whether 
EHD format or permissions are causing this problem, try exporting a single year or album 
to your Mac desktop and see if it exports correctly. Contact us with your findings. 

 
12. The original dates were not retained in the photos that I exported. In Finder when I 

right-click and select Get Info, they all show “Created” date as “Today”. 
 
  The “Created” date shown by Finder isn’t the EXIF date but the date when a photo was 

saved to its current location. Open the photo with Preview > click Tools > Show Inspector 
> EXIF, and you’ll see the EXIF Date. 

 

         
 

13. Why did formats of some HEIC files change to JPG upon exporting? 

 

Photos Takeout exports edited HEIC items as JPG and edited MP4 files as MOV. This is 
consistent with how Photos does it. This doesn’t happen for unmodified originals.  

 
14. How to export Favorites, Shared Albums and smart albums? 
 

Click on the Albums tab and scroll all the way down to see Favorites and Shared Albums. 
Select and export these just like other albums. Note that Shared Albums store photos and 
video in reduced quality (2448px along the longer edge for photos, 720p for videos), and 
strips most metadata. Items exported with Photos Takeout will inherit these diminutions.  
 
To export a smart album, save it as a regular album under My Albums, then you’ll be 
able to export it like other albums. 

  
15. I want a complete backup. If I export all albums, that won’t be complete because 

photos not assigned to any album will be left out. What to do? 
 

In Photos app, click File > New Smart Album, and use the following settings to create a 
smart album of all unassigned photos. Then convert it to a regular album and export: 
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16. I can export Year- and Date-wise folders, but how to export month-wise folders?  
 
Export Years and check mark the 'Keep subfolders' box in the Export Options panel. 
 

17. How to avoid files being renamed as albumname-NNN when I export an album?  
 
Uncheck the Export Albums > Ordered Albums box (‘Ordered Albums’ option is for users 
who’ve custom-arranged photos in albums, and want to retain this ordering on export.) 
 

18. How does Photos Takeout handle export of raw images? 

 

Raw photos may have been imported into Photos as raw-only or raw-jpeg pairs. For both 
cases, Photos Takeout exports according to the following rule: 

 

- Unmodified check-marked: Only the unedited original RAW file will be exported. 

- Unmodified unchecked: Only the latest edited JPG version will be exported. 

 

19. All photos in my library on EHD are stored locally - it’s too big for Mac or iCloud. If I 
set it as my system photo library, won’t it start uploading to iCloud? 

 

No need to upload the photos to iCloud – or even to Mac. Use the following workflow: 

 

- Temporarily disconnect the Mac from iCloud. See how. 

- Connect EHD to Mac. In Photos Preferences, make the EHD library the system library. 

- Launch Photos Takeout and export whatever you want 

- Reverse Step 2 (Disconnect EHD; revert to normal Photos and iCloud settings). 

 
20. I have Optimize Mac Storage checked in Photos Settings. If I export all photos, will 

everything be downloaded to Mac? What if the Mac runs out of disk space? 
 

In Catalina and later, Photos Takeout fetches items directly from iCloud. iCloud manages 
disk space dynamically, so if your Mac runs out of space, iCloud will download fewer files. 
After Photos Takeout exports these, iCloud will re-optimize and use the space thus freed 
up to download more files. This will be slower than if the Mac has ample disk space.  
 
In Mojave and older, you must first download photos saved in iCloud and then export. If 
your Mac is short on space, move the library to an external drive (See how), set it as the 
system photo library, wait for it to sync with iCloud, then export. This will download items 
from iCloud to the library on the external drive instead of Mac. 

 

https://support.apple.com/en-in/guide/icloud/mmb1de40d9/icloud
https://support.apple.com/en-gb/HT201517
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21. The export is taking inordinately long. The progress indicator is stuck. 

 
You must have some processing headroom (i.e. 10-15% of iCloud and Mac storage 
free), and sufficient free space at the destination. Downloads from iCloud also take 
long if you have many files or a slow wi-fi. If all’s well, exporting a 100GB library – as a 
reference benchmark – shouldn’t take more than 2-3 hours. 

 

22. In my Photos Settings, “Copy items to the Photos library” is unchecked, i.e. 
photos are stored as referenced files. These failed to export.  

 
In Big Sur and later, you need to give Photos Takeout full disk access. Quit Photos 
Takeout. Open System Preferences > Security & Privacy > Privacy > in Left pane, 
select Full Disk Access > In Right pane, click (+) and add Photos Takeout to the list 
and check mark it > Reboot the Mac. Now the referenced files will be exported.  

 

23. Why is face recognition information not exported as part of metadata? 
 

Face data is not part of EXIF or IPTC metadata. A workaround for preserving this info: 
Add names of people in the photos as keywords (Go to People view in Photos > click 
on a face > photos are displayed > Select all > right click, Get Info > add the person's 
name in keywords. To export all photos of a person, go to People tab, select all photos 
featuring that person, and put them in an album. You can then export this album. 

 

24. If I re-export albums or years, will I get duplicate files and folders or updated assets 
including those added since last export? 
 
Depends on whether the Incremental Exports box is checked on not: 
 
If it is checked AND you’ve subscribed to this service, only the assets added or modified 
since the last export are exported. Please see the Incremental Exports guide for details. 
 
 
If not exporting incrementally, selecting the same location (path) will add duplicate files in 
the previously exported folders; e.g. file XYZ will be duplicated as XYZ0. If you edited this 
file since the last export, XYZ0 will reflect the edits. If you export to a different path, all the 
folders will be created afresh and the latest set of photos saved in them. 

 
25. My Live Photos were exported as JPG/HEIF. What about the video? 

 
The video component of Live Photos is converted to MOV files and saved in a separate 
folder at the export destination. 
 

26. Why did the keywords not export? 
 
Check whether you check marked ‘Keep Metadata’ and unchecked ‘Unmodified’. Another 
possibility is that you input them as Finder Tags, and not as Keywords. Finder tags are 
not treated as EXIF or IPTC metadata, and therefore not supported by our app.   
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OTHER 
 

1. Does Photos Takeout work with iPhoto or Aperture libraries? 

 
No, Photos Takeout is only meant for Photos app. Not iPhoto or Aperture. 

 
2. I have an old Photos library (probably Mojave or Big Sur) on an external drive, and 

Photos Takeout on a newer Mac. How to export from this library on the new Mac? 
 

First update the Photos library. Make a copy of the library, connect the external drive to 
the new Mac, and open the library with the Photos app. You’ll be asked whether to 
update it; say yes. Once it is updated, quit Photos and use Photos Takeout to export. 
 

3. Why do you recommend exporting to an APFS formatted external drive? I’ll want to 
use the photos on a Windows PC, so can I use an ExFAT format drive instead? 

 
You can use an ExFAT format drive, but please be aware of its inherent limitations. 
 

4. Why do you recommend against exporting to a NAS? 
 
Photos Takeout has no problems exporting to a NAS, but it should be set up to work 
correctly with Mac and allow the Mac to write to it. If you experience any difficulty, it’ll 
likely be due to permissions issues. More details here. 

 
5. My question isn’t answered here. How to get Customer Support? 

 
Click Help > Contact Us in the app’s top menu bar. Include a detailed description of the issue 
and, if possible, a screenshot of the issue. Also mention: 
 
- MacOS version, Photos Takeout version 
- Photos library’s size (GB), items count, and location (whether on Mac or EHD?) 
- Location of photos: Locally (in Mac Photos), iCloud (Optimized or not), or referenced 
- Export destination (Mac, external drive, NAS, cloud storage etc.) 
 
If you use Facebook, a valuable resource is our Facebook page, where we post news of feature 
updates, tips and tricks, bug alerts and temporary workarounds for these, etc. Follow us. 

 

Contact Customer Support: Click here  
 

  

https://photostakeout.com/apfs-vs-exfat/
https://photostakeout.com/mac-to-nas/
http://www.facebook.com/photostakeout
mailto:support@photostakeout.com
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KNOWN ISSUES 
 
1. Some features aren’t available in Mojave and older. For example, photos and videos 

saved in iCloud must be downloaded to the local library before export; keywords are 
not exported; new features like List View and Incremental Exports aren’t available. 
 

2. Metadata added to videos via the Photos app is not retained upon export (Note that 
this also happens on exporting with Photos app – Date & Time original are retained 
only when you exported unedited originals, not in edited videos). 

 
3. When exporting the folder-subfolder-albums hierarchy (with ‘Keep folders’ check 

marked), the albums and folders must have distinct names. If an album has the 
same name as its parent folder, photos will be saved in the parent folder. 

 

 
Follow Photos Takeout on Facebook for the latest news on features, tips & tricks etc. 
  
 
 

Check out our other apps: 
 

 
 

 

Pic Scanner Gold 
(iOS) 

Created in 2013, Pic Scanner was the world's first mobile app 
for scanning and auto-cropping multiple photos at a time. It 
offers unlimited scanning and great features for a one-time 
price. No subscription or in-app purchases. One million users!  

   
 

 

SnipTag 
(macOS) 

If scanning photos, don’t start without these 2 powerful tools: 
1) Snip: Scan multiple photos per scan with a scanner or digital 
camera. Batch-crop them all with just one click. 
2) Tag: Batch-edit creation date, description, location and 
other metadata tags.  

 
 

  

 

Joggle 
(iOS and Android) 

A completely original, mildly cerebral word game inspired by 
crossword puzzles. Thousands of one-minute puzzles to 
entertain and exercise your brain. Free. Try it now! 

 
  

http://www.facebook.com/PhotosTakeout
https://www.picscannergold.com/
http://www.sniptagapp.com/
https://apps.apple.com/us/app/joggle-word-puzzle/id1622331915
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Footnotes 
 

1 Permissions need to be checked only if you are using macOS Big Sur or later. If Photos Takeout is listed in 
the right pane as shown below, check mark it to grant Full Access to the Photos Library: 
 

 
 
 
2 System Settings (macOS Ventura and later) was called System Preferences in older versions of macOS: 
 

 
 
 
3 If you have only one Photos library, then it is the System Photo Library and you don’t need to worry about this 
requirement. It you have multiple Photos libraries, only one of them can be the System Photo Library. Only this 
one syncs with iCloud and other devices and can support Shared Albums – so if you want to export iCloud-
based photos or shared albums, the Source must be the System Photo Library. Also, if you use a non-System 
Photo Library as the source, the photos containing edits may not export correctly. 
 
If you have more than one library and need to export from one that’s not System Photo Library, go to Photos > 
Settings > General (See below), click to the right of Library Location, navigate to the library and set it as the 
System Photo Library. This will turn off iCloud, and you may get an alert that any photos that are only in iCloud 
will be removed from your (iCloud-synced) library. Let it happen. Then set this new System Photo Library as 
the Source in Photos Takeout and do your export. After it’s done, again open Settings and change the System 
Photo Library back to the original Library. It’ll sync with iCloud and photos that were removed will be restored.   
 

 
 
 
4 We recommend APFS / Extended Journaled formats throughout this document because they work best with 
Apple hardware. Don’t use FAT32, especially if you have videos, as it has a 4GB file size limit. EXFAT doesn’t 
have the 4GB limit and may work. If you must use an EXFAT drive, format it with the Mac’s Disk Utility and not 
on a Windows PC. Don’t use NTFS – both MacOS and Windows can read it but MacOS can’t write to it. If 
exporting to an EXFAT drive or NAS, do a small test export to see if files are saved correctly.  
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5 To select the Source Library, navigate to its location on your Mac or external drive. On the Mac, its default 
location is in the Pictures folder (Marked by red arrow below, NOT Media > Photos further down), and its icon 
is the same as that of the Photos app. Single-click to select it, then click Open. Don’t double-click the Library 
icon – doing so will display the folders within it, which you don’t want.  
 

  
 
6 When you launch Photos Takeout, it opens in Icon View, but you can switch to List View using the little icons 
in the Years or Albums tabs. List View allows more granular selection of months within years, and reduces the 
scrolling and searching effort if you have a large number of albums and folders: 
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